Content Editor Webpart Error On Page

Posted: May 27, 2011 in Content Editor webpart, Error on page, sharepoint 2007, Unexpected error has occured
Tags: ,
Issue: Unable to move Content Editor webpart from one place to another. We get the following error message “Error On page” on the Bottom left of the IE.
Or
After moving the content Editor webpart , when we click Exit edit mode . It gives “Unexpected error has occured”.
 
Cause: This usually happens whenever we copy the HTML code from one Content Editor webpart to another. When we copy the HTML code it also copies the Webpart ID and it conflicts.

Resolution: Open the Site in Firefox\Chrome browser as IE will not give you the Drop down to edit the webpart
Modify the Content Editor Webpart
Open the Source Code
Remove the following Tag from the code for eg:- “id=WebPartWPXX WebPartID=”XXXX-XXXX-XXXX-XXXX-XXXXXXXX
Click Apply – OK
You can then move the webparts without any issues

Advertisements
Comments
  1. Natalie Parker says:

    THANK you! Thank YOU! THANK YOU!
    This has perplexed and plagued me forever and it is so hard to find help on this one. You are exactly right! All fixed!!

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s